Archive for February, 2011


N900 – No sound after boot

Hi!

Just wanted to save this information somewhere in the hope of it being useful to someone sometime 😛

If you have no sound after boot and increasing volume doesn’t work it is likely pulseaudio failed to start. Some minutes after boot it is possible to start pulseaudio via terminal (as root) (

start pulseaudio

) but if you forget you end up with no sound which is I’d say pretty bad for a phone… -.-

So what do you have to do?

Execute this command as root:

cp /opt/maemo/usr/lib/libFLAC.so.8.2.0 /usr/lib/libFLAC.so.8.2.0

What causes the problem seems to be that pulseaudio wants to start when /opt is not mounted yet and libFLAC seems to have been (accidently) moved to /opt when it should have stayed out…

I do not guarantee it works but at least for me (and some guys on tmo) it worked 🙂

After some googling I found the solution here (no it is not from me)

Hope this helps you 🙂

Advertisements

Hello!

I recently found out about the buildservice plugin (OBS, Meego) for Qt Creator (branch: buildservice). I wanted to give it a try and sadly I had to compile an old instance of QtCreator as it was based on an old version of QtCreator.

Therefore I just patched it to work with current master of QtCreator.

You can find the patch here. (okay I actually wrote this article 5 days ago but I had to overcome some hurdles to setup my server… -.-)

I’ll lo0k into contacting the project Bretzn developers to rebase their repo onto the current master of QtCreator. Will report back if they plan to do it soon 🙂

PS: this patch should apply cleanly to qtcreator master – it is only a small diff compared to the buildservice branch (I think only one cpp file changed (changed a list to a custom class as an interface in QtCreator changed))