Archive for April, 2010


Firefox-Qt updated!

Looks like I found a purpose for this blog 😛 another update on the firefox-qt effort…

I just updated the ArchLinux pkbuild to 3.6.3 – and guess what… the situation has improved! menus AND dialogs are working 🙂 … well sort of…

but see for yourself:

keyboard would be a cool thing to have next 😀 stay tuned for further updates – looks like this is a cool balancer for the work I GOTTA do ^^

PS: as always: THIS WILL EAT YOUR KITTENS!

Long time no blog… yeah I know… nobody cares ^^ the internet is full of random guys who post SOMETHING… well.. take a guess… I did something which not THAT many guys did so far (I think) ^^

I had some fun packaging firefox-qt .. yes you heard it right… firefox with it’s Qt rendering frontend 🙂
don’t freak out yet… it… well… the good things first… it builds and installs… and WOW… it even starts 😀
And guess what… browsing works

Well… sort of… clicking is a luxury nobody needs… and… well… do you care about your keyboard? I hate to type… so firefox-qt got rid of that problem for me 😀

For those looking for a screenshot… here it comes… who needs a visual scrollbar? or clickable menu bars?

You may ask yourself how to get it to run… Are you on ArchLinux? Then your chances of getting it to work are rather high 🙂 on other distros you can maybe take some guesses from the PKGBUILD files on how to get it to run… or the patches… take whatever you need 😀

On ArchLinux Two packages are needed to get it to work:

xulrunner-qt (http://aur.archlinux.org/packages.php?ID=36107)

firefox-qt (http://aur.archlinux.org/packages.php?ID=22050)
old download links: http://friesoft.mh1.at/firefox-qt-3.6.2-1.src.tar.gz (thx to a good friend for providing me with the space 🙂

Warnings:

  • YES this WILL eat your hamster! – no it won’t survive that sorry
  • DON’T use your default profile for that – it will break/segfault on startup
  • the package dependencies are MORE THAN suboptimal…
  • the compilation itself MAY have wrong parameters – I don’t know – I just tried to get it to work…. somehow…
  • YOU WILL HAVE TO UNINSTALL firefox and xulrunner BEFORE! /etc/gre.d and the file inside aren’t compatible… don’t know how to change that…
  • other than that: firefox-qt installs to /opt/ffqt

These packages are 1:1 based on the current firefox and xulrunner packages I got with pacman (I got the source using pacman -G firefox xulrunner), I didn’t modify any copyright, etc… this was just a “Make-it-work-thingy”… Everything needed to get it to work isn’t really my work – I just put it together.. from various sites… ranging from wikis to some strange japanese sites

Well… happy testing… happy bugfixing (hopefully)… and happy hacking (you gotta do that if you want firefox-qt to succeed)… sadly I don’t have enough time to do it myself…